Naming Unit Tests that just calls a constructor?
Posted
by Thomas Jespersen
on Stack Overflow
See other posts from Stack Overflow
or by Thomas Jespersen
Published on 2010-05-15T16:36:05Z
Indexed on
2010/05/15
16:44 UTC
Read the original article
Hit count: 304
unit-testing
|naming
I'm trying to follow Roy Osherove's UnitTests naming convention, with the naming template: [MethodName_StateUnderTest_ExpectedBehavior].
Following this pattern. How would you name a test calling a constructor?
[Test]
public void ????()
{
var product = new Product();
Assert.That(product, Is.Not.Null);
}
© Stack Overflow or respective owner