What should I name instances of a twisted.internet.defer.Deferred?
Posted
by
slacy
on Stack Overflow
See other posts from Stack Overflow
or by slacy
Published on 2012-10-16T17:55:25Z
Indexed on
2012/10/16
23:00 UTC
Read the original article
Hit count: 165
I'm writing code using Twisted, and having trouble coming up with a sensible variable name for my twisted internet deferred's. Here are my candidates:
d
: Too generic, too short, violates pylint rule C0103.def
: Conflicts with function defintion builtin.defer
: Conflicts with module twisted.internet.deferdeferred
: OK but pretty longcb
: Still too short, violates pylint C0103, conflicts with many callback method names.cback
: Too Weird?callback
: Conflicts with method Deferred.callback()
I'm looking for other suggestions. It seems like most of the Twisted example code uses "d" which is fine for simple invocations, but when you're passing Deferred's around to methods and storing them as member variables, it's really far too descriptive.
© Stack Overflow or respective owner