Configuring CESoPSN using Cisco MWR 2941
- by Rayne
I'm trying to configure CESoPSN on two Cisco MWR 2941 routers, but the alarm LED lights are always lit. My configuration is modeled after this sample configuration.
My setup is as follows:
On the Cisco MWRs, E1 0/5 is configured to be CESoPSN, E1 0/9 is configured to be CESoPSN (CAS mode), and E1 0/7 is configured to be SAToP. The two MWRs are connected to each other via the GigabitEthernet port 0/2. The GigE ports are configured as a vlan because the ports are L2 ports and cannot be assigned an IP address directly.
The two Cisco MWRs are connected to a traffic simulator, i.e. the traffic simulator will play out E1 traffic to MWR 1 and record the output traffic from MWR 2.
On my traffic simulator, when it's connected to the E1 ports 0/5 and 0/9 (both CESoPSN configurations), the "Remote" alarm is on. However, when connected to the E1 ports 0/7 (SAToP configuration), no alarms were on.
The GigE connection seems to be working fine (both LED lights on the 2 ports are green). The SAToP configuration seems to be fine too (Left LED is green, right LED is off on both E1 0/7 ports).
However, both CESoPSN configurations seem to be not working (Left LED is green, right LED is yellow on both E1 0/5 and 0/9 ports).
I don't know if there's anything wrong with my configuration for the CESoPSN, as I'm very new to this.
The relevant portions of the configuration are as follows:
MWR 1:
controller E1 0/5
clock source internal
cem-group 5 timeslots 1-31
description E1 CESoPSN example
!
controller E1 0/7
clock source internal
cem-group 7 unframed
description E1 SATOP example
!
controller E1 0/9
mode cas
clock source internal
cem-group 9 timeslots 1-24
description E1 CESoPSN CAS example
!
interface Loopback0
ip address 30.30.30.1 255.255.255.255
!
interface GigabitEthernet0/2
switchport access vlan 100
mpls ip
!
interface CEM0/5
no ip address
cem 5
xconnect 30.30.30.2 305 encapsulation mpls
!
!
interface CEM0/7
no ip address
cem 7
xconnect 30.30.30.2 307 encapsulation mpls
!
!
interface CEM0/9
no ip address
cem 9
signaling inband-cas
xconnect 30.30.30.2 309 encapsulation mpls
!
!
interface Vlan100
ip address 50.50.50.1 255.255.255.0
no ptp enable
mpls ip
!
no ip classless
ip forward-protocol nd
ip route 30.30.30.2 255.255.255.255 50.50.50.2
!
MWR 2:
controller E1 0/5
clock source internal
cem-group 5 timeslots 1-31
description E1 CESoPSN example
!
controller E1 0/7
clock source internal
cem-group 7 unframed
!
controller E1 0/9
mode cas
clock source internal
cem-group 9 timeslots 1-24
description E1 CESoPSN CAS example
!
interface Loopback0
ip address 30.30.30.2 255.255.255.255
!
interface GigabitEthernet0/2
switchport access vlan 100
mpls ip
!
interface CEM0/5
no ip address
cem 5
xconnect 30.30.30.1 305 encapsulation mpls
!
!
interface CEM0/7
no ip address
cem 7
xconnect 30.30.30.1 307 encapsulation mpls
!
!
interface CEM0/9
no ip address
cem 9
signaling inband-cas
xconnect 30.30.30.1 309 encapsulation mpls
!
!
interface Vlan100
ip address 50.50.50.2 255.255.255.0
no ptp enable
mpls ip
!
no ip classless
ip forward-protocol nd
ip route 30.30.30.1 255.255.255.255 50.50.50.1
!
If anyone is familiar with CESoPSN configurations, please advise.