What to name an array of flags?
- by Chris
I have a project where lots of the objects hold state by maintaining simple boolean flags. There are lots of these, so I maintain them within a uint32_t and use bit masking. There are now so many flags to keep track of, I've created an abstraction for them (just a class wrapping the uint32_t) with set(), clear(), etc.
My question: What's a nice accurate, concise name for this class? What name could I give this class so that you'd have a reasonable idea what it was [for] knowing the name only?
Some ideas I had:
FlagBank
FlagArray
etc
Any ideas?
Thanks in advance!
Cheers,
-Chris