Naming Convention for Dedicated Thread Locking objects
- by Chris Sinclair
A relatively minor question, but I haven't been able to find official documentation or even blog opinion/discussions on it.
Simply put: when I have a private object whose sole purpose is to serve for private lock, what do I name that object?
class MyClass
{
private object LockingObject = new object();
void DoSomething()
{
…