code style for private methods in c#
- by illdev
I just found out, that it seems a common pattern to user UpperFirstLetterPascalCase() for private methods. I for myself, find this completely inconsistent with naming rules of private instance fields and variables and I find it difficult to read/debug, too.
I would want to ask, why using a first upper letter for methods could be a better choice than a first lower (doThis())? Just out of curiosity...