Unnecessary code...
- by Martin Milan
Suppose I have some code that looks like this:
Private Sub MySub()
dim blnFlag as Boolean
blnFlag = False
for each item in collection
if item.Name = "Mike" then
blnFound = true
exit for
endif
next item
End Sub
Now - the blnFLag = False assignment is not actually necessary - booleans are initialised as false, but I think it's inclusion makes the code easier to read. What's your opinion?