QoS for Cisco Router to Prioritize Voice and Interactive Traffic

Posted by TJ Huffington on Server Fault See other posts from Server Fault or by TJ Huffington
Published on 2010-03-27T17:52:44Z Indexed on 2010/03/27 18:03 UTC
Read the original article Hit count: 785

Filed under:
|
|
|
|

I have a Cisco 891W NATing Voice and Data to the internet over a 10mbit/2mbit connection. Voice traffic gets degraded when I upload large files. Pings time out as well.

I tried to configure a QoS policy but it's basically not doing anything. Voice traffic still degrades when upload bandwidth gets saturated.

Here is my current configruation:

class-map match-any QoS-Transactional
 match protocol ssh
 match protocol xwindows
class-map match-any QoS-Voice
 match protocol rtp audio
class-map match-any QoS-Bulk
 match protocol secure-nntp
 match protocol smtp
 match protocol tftp
 match protocol ftp
class-map match-any QoS-Management
 match protocol snmp
 match protocol dns
 match protocol secure-imap
class-map match-any QoS-Inter-Video
 match protocol rtp video
class-map match-any QoS-Voice-Control
 match access-group name Voice-Control

policy-map QoS-Priority-Output
 class QoS-Voice
    priority percent 25
  set dscp ef
 class QoS-Inter-Video
    bandwidth remaining percent 10
  set dscp af41
 class QoS-Transactional
    bandwidth remaining percent 25
     random-detect dscp-based
  set dscp af21
 class QoS-Bulk
    bandwidth remaining percent 5
     random-detect dscp-based
  set dscp af11
 class QoS-Management
    bandwidth remaining percent 1
  set dscp cs2
 class QoS-Voice-Control
    priority percent 5
  set dscp ef
 class class-default
    fair-queue

interface FastEthernet8
 bandwidth 1024
 bandwidth receive 20480
 ip address dhcp
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
 auto discovery qos
 crypto map mymap
 max-reserved-bandwidth 80
 service-policy output QoS-Priority-Output

crypto map mymap 10 ipsec-isakmp
 set peer 1.2.3.4 default
 set transform-set ESP-3DES-SHA
 match address 110
 qos pre-classify
!

fa8 is my connection to the internet. Voice traffic goes over a VPN ("mymap") to the SIP server. That's why I specified "qos pre-classify" which I believe is the way to classify traffic over the VPN. However even when I ping a public IP while saturating upload bandwidth, the latency is exceptionally high.

Is this configuration correct? Are there any suggestions that might make this work for my setup?

Thanks in advance.

© Server Fault or respective owner

QoS for Cisco Router to Prioritize Voice and Interactive Traffic

Posted by TJ Huffington on Super User See other posts from Super User or by TJ Huffington
Published on 2010-03-27T17:42:05Z Indexed on 2010/03/27 17:43 UTC
Read the original article Hit count: 785

Filed under:
|
|
|
|

I have a Cisco 891W NATing Voice and Data to the internet over a 10mbit/2mbit connection. Voice traffic gets degraded when I upload large files. Pings time out as well.

I tried to configure a QoS policy but it's basically not doing anything. Voice traffic still degrades when upload bandwidth gets saturated.

Here is my current configruation:

class-map match-any QoS-Transactional
 match protocol ssh
 match protocol xwindows
class-map match-any QoS-Voice
 match protocol rtp audio
class-map match-any QoS-Bulk
 match protocol secure-nntp
 match protocol smtp
 match protocol tftp
 match protocol ftp
class-map match-any QoS-Management
 match protocol snmp
 match protocol dns
 match protocol secure-imap
class-map match-any QoS-Inter-Video
 match protocol rtp video
class-map match-any QoS-Voice-Control
 match access-group name Voice-Control

policy-map QoS-Priority-Output
 class QoS-Voice
    priority percent 25
  set dscp ef
 class QoS-Inter-Video
    bandwidth remaining percent 10
  set dscp af41
 class QoS-Transactional
    bandwidth remaining percent 25
     random-detect dscp-based
  set dscp af21
 class QoS-Bulk
    bandwidth remaining percent 5
     random-detect dscp-based
  set dscp af11
 class QoS-Management
    bandwidth remaining percent 1
  set dscp cs2
 class QoS-Voice-Control
    priority percent 5
  set dscp ef
 class class-default
    fair-queue

interface FastEthernet8
 bandwidth 1024
 bandwidth receive 20480
 ip address dhcp
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
 auto discovery qos
 crypto map mymap
 max-reserved-bandwidth 80
 service-policy output QoS-Priority-Output

crypto map mymap 10 ipsec-isakmp
 set peer 1.2.3.4 default
 set transform-set ESP-3DES-SHA
 match address 110
 qos pre-classify
!

fa8 is my connection to the internet. Voice traffic goes over a VPN ("mymap") to the SIP server. That's why I specified "qos pre-classify" which I believe is the way to classify traffic over the VPN. However even when I ping a public IP while saturating upload bandwidth, the latency is exceptionally high.

Is this configuration correct? Are there any suggestions that might make this work for my setup?

Thanks in advance.

© Super User or respective owner

Related posts about cisco

Related posts about qos