Am I missing a pattern?
- by Ryan Pedersen
I have a class that is a singleton and off of the singleton are properties that hold the instances of all the performance counters in my application.
public interface IPerformanceCounters
{
IPerformanceCounter AccountServiceCallRate { get; }
IPerformanceCounter AccountServiceCallDuration { get; }
Above is an incomplete snippet of the interface for the class "PerformanceCounters" that is the singleton.
I really don't like the plural part of the name and thought about changing it to "PerformanceCounterCollection" but stopped because it really isn't a collection. I also thought about "PerformanceCounterFactory" but it is really a factory either. After failing with these two names and a couple more that aren't worth mentioning I thought that I might be missing a pattern.
Is there a name that make sense or a change that I could make towards a standardized pattern that would help me put some polish on this object and get rid of the plural name?
I understand that I might be splitting hairs here but that is why I thought that the "Programmers" exchange was the place for this kind of thing. If it is not... I am sorry and I will not make that mistake again.
Thanks!