Search Results

Search found 89606 results on 3585 pages for 'feed me code'.

Page 247/3585 | < Previous Page | 243 244 245 246 247 248 249 250 251 252 253 254  | Next Page >

  • Safest way to change variable names in a project

    - by kamziro
    So I've been working on a relatively large project by myself, and I've come to realise that some of the variable names earlier on were.. less than ideal. But how does one change variable names in a project easily? Is there such a tool that can go through a project directory, parse all the files, and then replace the variable names to the desired one? It has to be smart enough to understand the language I imagine. I was thinking of using regexp (sed/awk on linux?) tools to just replace the variable name, but there were many times where my particular variable is also included as a part of strings. There's also the issue about changing stuff on a c++ namespace, because there is actually two classes in my project that share the same name, but are in different namespaces. I remember visual stuio being able to do this, but what's the safest and most elegant way to do this on linux?

    Read the article

  • Is saving to database just to get an ID a bad hack?

    - by Narsil
    I hope the title is not too confusing. I am trying to make folders with linq-to-sql objects' IDs. Actually I have to create folders before I should save them. I will use them to keep user uploaded files. As you can see I have to create the folder with the FileID before I can save it there. So I just save a record which will be edited or maybe deleted File newFile = new File(); ...//add some values to fields so they don't throw rule violations db.AddFile(newFile); db.Save(); System.IO.Directory.CreateDirectory("..Uploads/"+newFile.FileId.ToString()); After that I will have to edit some fields and save again. Of course user might stop upload and I would have to delete it. I know I can write a stored procedure to get the next available FileID but some other upload happening at the same time would get the same number. So they would write in same directory which is a thing I don't want. Should I go on with this, would there be some problems? Can you think of a better way?

    Read the article

  • Use continue or Checked Exceptions when checking and processing objects

    - by Johan Pelgrim
    I'm processing, let's say a list of "Document" objects. Before I record the processing of the document successful I first want to check a couple of things. Let's say, the file referring to the document should be present and something in the document should be present. Just two simple checks for the example but think about 8 more checks before I have successfully processed my document. What would have your preference? for (Document document : List<Document> documents) { if (!fileIsPresent(document)) { doSomethingWithThisResult("File is not present"); continue; } if (!isSomethingInTheDocumentPresent(document)) { doSomethingWithThisResult("Something is not in the document"); continue; } doSomethingWithTheSucces(); } Or for (Document document : List<Document> documents) { try { fileIsPresent(document); isSomethingInTheDocumentPresent(document); doSomethingWithTheSucces(); } catch (ProcessingException e) { doSomethingWithTheExceptionalCase(e.getMessage()); } } public boolean fileIsPresent(Document document) throws ProcessingException { ... throw new ProcessingException("File is not present"); } public boolean isSomethingInTheDocumentPresent(Document document) throws ProcessingException { ... throw new ProcessingException("Something is not in the document"); } What is more readable. What is best? Is there even a better approach of doing this (maybe using a design pattern of some sort)? As far as readability goes my preference currently is the Exception variant... What is yours?

    Read the article

  • NetBeans shortcut key for collapsing/expanding a method

    - by Stefanos Kargas
    JAVA - NETBEANS This is an IDE question I am always working with collapsed methods, because I want to be able to see my methods all together. This is a little time consuming because I have to use the mouse to scroll up to the declaration of the method and click on the - (minus) icon. And then respectively go to the method I want to work on and click on the + (plus) icon. Is there a way through a keyboard shortcut to do the collapse (and respectively the expand)?

    Read the article

  • Get Object ID of UI element from code.

    - by andoriyu.mp
    I'm trying link 40 buttons to one event handler method and then do the processing work from one method instead of 40. I know how to link it but once I get there I don't know how to distinguish what button was pressed. Does anyone know how to reference the button object sender id or is there another way to solve this problem? Any help would be greatly appreciated.

    Read the article

  • Vim html.erb snippets?? snipMate Need a vim tip!

    - by Daniel Upton
    Hi, I've started using Vim for my rails development (who hasn't!).. And i'm loving it except that when im in a html.erb file (HTML and Ruby).. I get no snipMate snippets, I would like both html and ruby... or just html would be fine, How would i do this? Would i need to write a set of snippets? if so is there a way of pulling in existing snippets without copying them? Is there a way of telling vim to go into html mode when it sees .html erb? Thanks Daniel

    Read the article

  • where to store helper functions?

    - by ajsie
    i've got a lot of functions i create or copy from the web. i wonder if i should store them in a file that i just include into the script or should i store each function as a static method in a class. eg. i've got a getCurrentFolder() and a isFilePhp() function. should they be stored in a file as they are or each in a class: Folder::getCurrent() File::isPhp(); how do you do? i know this is kinda a "as u want" question but it would be great with some advices/best practices thanks.

    Read the article

  • Function call within XAML code?

    - by Matt H.
    I'd like to set a style on all my TextBox controls that does the following when it receives keyboard focus: 1) Change the background color 2) Call .SelectAll() to highlight all text I have this so far: <Style TargetType="TextBox"> <Style.Triggers> <Trigger Property="IsKeyboardFocusWithin" Value="True"> <Setter Property="Background"> <Setter.Value> <SolidColorBrush Color="#FFFFD1D9"/> </Setter.Value> </Setter> </Trigger> </Style.Triggers> </Style> Is there a way to also call .SelectAll() ? Thanks.

    Read the article

  • PHP Code to Generate Simple Flowchart

    - by revbackup
    I am making a flowchart out the subjects in the curriculum of our school. a flowchart is generated through its preRequisite.... for example FIRST YEAR FIRST SEMESTER SUBJECTS ---- PREREQUISITE MATH 1 ---- NONE MATH 2 ---- NONE ENGL 1 ---- NONE SOCIO 1 ----- NONE POLSCI 1 ----- NONE FIRSTE YEAR SECOND SEMESTER SUBJECTS ---- PREREQUISITE MATH 3 ----- MATH 1 MATH 4 ----- MATH 2, MATH 1 ENGL 2 ----- ENGL 1 POLSCI 2 ----- POLSCI 1 So, I must print it this way, just using simple PHP but difficult Logic.: MATH1 -----> MATH3 -----> MATH4 MATH 2 ----->MATH 4 ENGL1 -----> ENGL 2 SOCIO 1 POLSCI 1 -----> POLSCI 2 Can anyone give me a good algorithm for this, because this is really difficult. I am planning to echo the results in an HTML table, and it makes it more complicated. Do you have suggestions how to solve this problem properly and display the results also properly???? Thank you in advance!

    Read the article

  • Can anyone telme whats wrong in this part of code

    - by Mobin
    string name = ((DateTimePicker)sender).Name.ToString(); name = name.Substring(0, name.Length - 1); name = name + "4"; TimeSpan duration = new TimeSpan(); duration = ((DateTimePicker)sender).Value - ((DateTimePicker)panel2.Controls[name]).Value; name = name.Substring(0, name.Length - 1); name = name + "6"; ((MaskedTextBox)panel2.Controls[name]).Text = duration.ToString(); on execution it gives me Object reference not set to instance of an object similar functionality is used on other places but can't find out what i have to reinitialize here :$

    Read the article

  • Mistake in the Code

    - by vibha
    myTree.on('click',function(node){ if(node.isLeaf()) { Ext.Msg.alert("You are in value ",nodeValue,"whose name is",nodeName); alert("You are in value ",nodeValue,"whose name is",nodeName); } }); myTree is a TreePanel. I'm getting a tree but click function is not working. I'm very new to extjs. Help me out. Thanks in advance

    Read the article

  • SQL Code Smells

    - by Lijo
    Hi Team, Could you please list some of the bad practices in SQL, that novice people do? I have found the use of "WHILE loop" in scenarios which could be resolved using set operations. Another example is inserting data only if it does not exist. This can be achieved using LEFT OUTER JOIN. Some people go for "IF" Any other thoughts? Thanks Lijo

    Read the article

  • Executing certain code for every method call in C++

    - by Luís Guilherme
    I have a C++ class I want to inspect. So, I would like to all methods print their parameters and the return, just before getting out. The latter looks somewhat easy. If I do return() for everything, a macro #define return(a) cout << (a) << endl; return (a) would do it (might be wrong) if I padronize all returns to parenthesized (or whatever this may be called). If I want to take this out, just comment out the define. However, printing inputs seems more difficult. Is there a way I can do it, using C++ structures or with a workaroud hack?

    Read the article

  • Question regarding ip checksum code

    - by looktt
    unsigned short /* this function generates header checksums */ csum (unsigned short *buf, int nwords) { unsigned long sum; for (sum = 0; nwords > 0; nwords--) // add words(16bits) together sum += *buf++; sum = (sum >> 16) + (sum & 0xffff); //add carry over sum += (sum >> 16); //what does this step do??? add possible left-over //byte? But isn't it already added in the loop (if //any)? return ((unsigned short) ~sum); } I assume nwords in the number of 16bits word, not 8bits byte (if there are odd byte, nword is rounded to next large), is it correct? The line sum = (sum 16) + (sum & 0xffff) is to add carry over to make 16bit complement sum += (sum 16); What's the purpose of this step? Add left-over byte? How? Thanks!

    Read the article

  • How to stop htaccess rewrite rule carrying over query string

    - by geoffs3310
    I am setting up some redirects. I want to redirect the following URL: /cms/index.php?cat_id=2 to the following URL: /flash-chromatography The rule I currently have is as follows: RewriteCond %{QUERY_STRING} ^cat_id=2$ [NC] RewriteRule ^cms/index\.php$ /flash-chromatography [L,R=301] This rule is almost perfect apart from it redirect the URL to the following: /flash-chromatography?cat_id=2 So you see my problem is it has kept the ?cat_id=2 part when I don't want it to. How do I stop it keeping this bit?

    Read the article

  • C puzzle: Output of printf should be '5' always

    - by pragadheesh
    Hi, I found this puzzle in a C aptitude paper. void change() { //write something in this function so that output of printf in main function //should always give 5.you can't change the main function } int main() { int i = 5; change(); i = 10; printf("%d", i); return 0; } Any solutions.?

    Read the article

  • Little help with some (simple) Javascript code

    - by lerac
    I'm a newb when it comes to javascript. Perhaps somebody could help me with this. I assume it is not very complicated. This is what I would like: <SCRIPT type=text/javascript> var StandardURL = "http://site/Lists/test/AllItems.aspx"; </script> <SCRIPT type=text/javascript> var FilterURL = "http://site/Lists/test//AllItems.aspx?FilterField1=Judge&FilterValue1="; </script> var DynamicURL = FilterURL + DynamicUserInf (no space between it should be like one url link), dynamicuserinf contains different value depending on the user that is logged in no need to worry what is in it. It already contains a value befor this runs Get current URL in [var CurrentURL] <script language="JavaScript" type="text/javascript"> if (CurrentURL == StandardURL) { location.href= (DynamicURL);} </script> ElSE do nothing (i assume this is not neccarry with only one if statement) Hopefully not much of a mess.

    Read the article

< Previous Page | 243 244 245 246 247 248 249 250 251 252 253 254  | Next Page >