How to name multi-setter?
- by IAdapter
I'm struggling with how to name this method, I don't like the "set" prefix, because I feel it should be reserved for normal "dumb" setters and some tools might not like it (i did not check it in checkstyle, pmd, etc., but I got a feeling they won't like it.)
for example (in java, but I feel its language agnostic)
public void setField1Field2(String field1, String field2) {
this.field1 = field1;
this.field2 = field2;
}
The only purpose of this method is ONLY to set, this method is needed and cannot be joined with any other (because of framework used).